Instalar Modem 3G ZTE 626 (Claro)

Recientemente contrate el servicio de Internet movil 3G de claro, un poco decepcionante el servicio por cierto, pero bueno eso es otro tema que talvez mencionare en otro post, el punto es que estos modem’s vienen con el instalador para Guindow$ y como no me gusta ese S.O., me puse a investigar como hacer funcionar este cacharrito en Ubuntu, no me costo mucho encontrar la respuesta,  lo encontre en este foro.

img

Antes de empezar, este mini tuto aplica solo la El Salvador, o por lo menos es lo que yo he probado, al configuración del proveedor dependedera me imagino del proveedor. Lo primero es  desconectar el modem si es que lo tienes conectado, ahora debes descargar los controladores respectivos, los puedes conseguir de esta pagina, busca la versión y la arquitectura correspondiente a tu Sistema, como es .deb solo le das doble click para instalarlo.

Nuestro segundo paso es editar el archivo  usb_modeswitch.conf, abrimos entonces una terminal y digitamos:

sudo gedit /etc/usb_modeswitch.conf

Cuando se abra el archivo, debes descomentarizar las lineas correspondientes a la entrada ZTE MF628+ , te quedara algo similar a esto:

########################################################
ZTE MF628+ (tested version from Telia / Sweden)
ZTE MF626

Contributor: Joakim Wennergren

DefaultVendor=  0x19d2
DefaultProduct= 0×2000

TargetVendor=   0x19d2
TargetProduct=  0×0031

MessageEndpoint=0×01
MessageContent=”55534243123456782000000080000c85010101180101010101000000000000″

# if that command doesn’t work, try the other (“eject”)
#MessageContent=”5553424312345678000000000000061b000000030000000000000000000000″

########################################################

Ahora si, procedemos a conectar el Modem, ya conectada y reconocido, digitamos en la consola el comando: lsusb, buscamos el ID 19d2:2000 lo que nos indicará que fue reconocido, no como modem pero como memoria.

OK entonces desde la terminal digitamos los siguientes comandos:

sudo /usr/sbin/usb_modeswitch -W -c /etc/usb_modeswitch.conf
sudo /sbin/modprobe usbserial vendor=0×19d2 product=0×0031
sudo gedit /usr/share/hal/fdi/information/20thirdparty/20-zte-mf626.fdi

El Ultimo nos abrira una ventana de Gedit, entonces dentro del documentos, debemos digitar el siguiente contenido:

<!– -*- SGML -*- –>
<deviceinfo version=”0.2″>
<device>
<!– ZTE MF626 HSDPA USB Modem –>
<match key=”@info.parent:usb.vendor_id” int=”0×19d2″>
<match key=”@info.parent:usb.product_id” int=”0×0031″>
<match key=”@info.parent:usb.interface.number” int=”3″>
<append key=”modem.command_sets” type=”strlist”>GSM-07.07</append>
<append key=”modem.command_sets” type=”strlist”>GSM-07.05</append>
<append key=”info.capabilities” type=”strlist”>modem</append>
</match>
</match>
</match>
</device>
</deviceinfo>

Guardamos el archivo y lo cerramos. A todo esto Ubuntu reconocio el modem como banda ancha movil y te muestra una ventana para configurarlo, en el asistente solo te muestra para El Salvador Movistar, no le tomes importancia, da siguiente y en el nombre le pones Claro.

Ahora si, nos tocara editar la configuracion de la conexion, entonces en la pestaña Banda ancha Movil, modifica el contenido de Numero con :*99#

Y en Nombre de AP: internet.ideasclaro

En la pestaña Ajustes de PPP, damos click en el boton de configurar metodos. ., desmarcamos todos los items excepto PAP, ok y en la pestaña Ajustes de IPv4, el metodo lo dejamos como automatico (PPP).

Con eso estamos listos, ya podras navegar con el cacharro ese, solo que hay una cosa que no he podido resolver, y es que siempre lo reconoce como usb y no como modem, pero la solucion es ejecutar:

sudo /usr/sbin/usb_modeswitch -W -c /etc/usb_modeswitch.conf

Basicamente conectas el modem, cuando el led cambie de rojo a azul o verde, ejecutas en la consola el comando anterior, lo volvera a montar pero hoy si como modem, luego de que vuelva a ponerse de color azul o verde, ya puedes seleccionarlo desde el applet de conexiones como Claro

Pues eso es todo, espero ayude.

Saludos.

About these ads

20 comments so far

  1. K@licheX on

    Yo realicé este tutorial hace varias semanas, lo ví en otra parte pero no recuerdo bien donde, y funciona, sólo tenía un problema que me aburría demasiado, cada 30 o 40 minutos se reiniciaba el modem y tocaba aplicar lo comandos nuevamente para que lo reconociera como modem, nunca encontré la forma de solucionar eso, así que me tocó cambiar el modem por un Huawei E156B que si lo reconoce de una sin necesidad de hacer nada.

    Felicidades por tu blog, lo leo a diario.

    • armandodiaz on

      Hola K@licheX gracias y me alegro te guste el blog, estoy intentando retomarlo por lo menos para los fines de semana xD, respecto al modem, pues fijate q lo he ocupado solo en la U, creo que por periodos algo largos y no me ha presentado problemas todavia, estare al tanto, por cierto el modem Huawei E156B canto te costo? y donde lo compraste, asi lo tendre en cuenta.
      Saludos.

      • K@licheX on

        En Colombia los modem ZTE 626, 616 y huawei E226, E156B, E160 no tienen costo en un plan de datos pospago, solo se paga al rededor del equivalente a U$4.50 por concepto de IVA, consguirlos libres cuesta alrededor del equivalente a U$75

  2. armandodiaz on

    Gracias por la info amigo, pense que eras de El Salvador XD por eso te pregunte lo del precio y el lugar.
    Saludos.

  3. Alberto on

    Soberbio maestro!!

    Para cuando le instale el Internet a mi padre, me va a servir mucho.

    Gracias por la info.

    Saludos!!

    • armandodiaz on

      No hay de que amigo.
      Saludos.

  4. lavidalinux on

    Muy bien detallado y explicado el tuto. Felicitaciones. Lastima que Claro El Salvador no distribuya el modem Huawei, o no te haya tocado uno a ti. Vivo en Argentina y tengo uno Claro el Huawei 262, sino recuerdo mal, que sólo lo conecté y automáticamente me sale el asistente de consiguración. Un par de clics y estoy navegando, sin instalar drivers ni nada. Si sirve, quiza puedan pedir a claro modems Huawei o solicitar que se le entregue uno de estos. un Saludo.

  5. Marvin on

    Supongo que se puede usar para un modem alcatel one touch x200?alguin lo ha probado en ubuntu8.0.4

  6. armandodiaz on

    lavidalinux: pues por el momento creo que solo el zte tienen disponible, buscare por ahí a ver si encuentro uno para probarlo.
    Marvin: pues fijate que con 8.04 no he probado. veremos si alguien que lo haya hecho te da una luz.

  7. Ben M! on

    Saludos! he provado toda la configuracion en ubuntu 9.04 y me lo reconoce y todo! pero no me conecta a internet.

    Lo he hecho literalmente como lo has indicado y nada…

    Les agradeceria su ayuda!

  8. armandodiaz on

    hola ben, si te cambia a azul?, en el applet te aparece la conexión a Claro? que te muestra la terminal despues del comando: sudo /usr/sbin/usb_modeswitch -W -c /etc/usb_modeswitch.conf
    Saludos.

  9. Ben M! on

    Si me cambia azul el led del modem! el applet me lo reconoce y todo! pero cuando eligo la red de banda ancha Claro intenta conectar, pero despues de unos segundo me dice “Red GSM desconectada”…
    La terminal me corresponde exitosamente luego de ingresar el comando….no hay problema en ello…no entiendo que sera!

  10. armandodiaz on

    mmm pues amigo Ben creo que entonces debe ser configuración, revisate bien la configuración porque aparamente por lo que me cuentas todo trabaja bien y es cuando intenta conectarse al servicio que falla. esta es la imagen que tengo:
    http://img198.imageshack.us/img198/2567/configclaro.png
    Saludos

  11. lavidalinux on

    Ese AP no está completo. La dirección debe finalizar .com o .com.xx extensión del país.

  12. armandodiaz on

    mmm pues a mi me funciona de esa manera.
    Saludos

  13. Ben M! on

    Pues…nada de nada! he provado con todo y aun no funciona!
    Siempre me da el mismo resultado “Red GSM desconectada” y ya probe con lo que tu le has puesto en la configuracion y nada!
    Que será?

  14. dax7xad on

    Saludos,

    Yo ya he logrado hacer que me funcione el moden gracias a los pasos de este post bueno casi

    Ya que la configuracion de la red no la dice

    o no es apta para todos los paises,
    mi caso particular soy de nicaragua
    entonces la configuracion es mas o menos asi
    usuario:webemovil
    contraseña:webemovil
    apn:web.emovil
    nota:uso en nicaragua
    entonces tienes que invesatigar la configuracion para tu pais

    Muchas gracias

    Post : un problema que tengo es que despues de usar el modem lo desconecto o reinicio la maquina y tengo que ejecutar el ultimo comando y andar probando en los puertos usb para ver donde me lo reconoce y despues de un tiempo lo hace
    alguna soluccion ????

  15. armandodiaz on

    Gracias por el aporte.. con el problema que tienes lo desconozco, de hecho a mi no me sucede eso. busca un poco en google, se que encontras la respuesta.
    Saludos.

  16. gustavo on

    yo tengo este mismo modem
    Cómo me conecto con el ubutu 9.10
    ?

    =/

  17. giyo.hdez! on

    hola quisiera saber que tal funciona el modem (inter) en
    El Salvador
    q opinan por sus experiencias…..
    quiero decidirme poor claro o por tigo…


Deja un comentario

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s

Seguir

Recibe cada nueva publicación en tu buzón de correo electrónico.

%d personas les gusta esto: